Missing Data in Reporting Module

Incident Report for Baseline

Resolved

The issue has been fixed and we are monitoring the results.
Posted Jun 08, 2026 - 16:40 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 08, 2026 - 16:33 CDT

Investigating

We are currently receiving reports of missing data in the reporting module as of 6/7/2026, we are investigating the issue now.
Posted Jun 08, 2026 - 15:17 CDT
This incident affected: Reporting.